blob: bd1e8576f323176e0e2dc72f481b491215fba749 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
3DRBD mirrors a block device over the network to another machine.\
4Think of it as networked raid 1. It is a building block for\
5setting up high availability (HA) clusters."
6HOMEPAGE = "http://www.drbd.org/"
7SECTION = "admin"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10
11SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
12 git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
13 file://0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \
14 "
15# v9.5.0
16SRCREV_drbd-utils = "ee126652638328b55dc6bff47d07d6161ab768db"
17SRCREV_drbd-headers = "b47cc11bcabe1a65c40ad23f71dcaf2da6419630"
18
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
22
23SYSTEMD_SERVICE_${PN} = "drbd.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
26inherit autotools-brokensep systemd
27
28EXTRA_OECONF = " \
29 --with-initdir=/etc/init.d \
30 --without-pacemaker \
31 --without-rgmanager \
32 --without-bashcompletion \
33 --with-distro debian \
34 --with-initscripttype=both \
35 --with-systemdunitdir=${systemd_unitdir}/system \
36 --without-manual \
37 "
38
39do_configure_prepend() {
40 # move the the file under folder /lib/drbd/ to /usr/lib/drbd when usrmerge enabled
41 if ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', 'true', 'false', d)}; then
42 for m_file in `find ${S} -name 'Makefile.in'`; do
43 sed -i -e "s;\$(DESTDIR)\/lib\/drbd;\$(DESTDIR)\${nonarch_libdir}\/drbd;g" $m_file
44 done
45 # move the the file under folder /lib/udev/ to /usr/lib/udev when usrmerge enabled
46 sed -i -e "s;default_udevdir=/lib/udev;default_udevdir=\${prefix}/lib/udev;g" ${S}/configure.ac
47 fi
48
49}
50do_install_append() {
51 # don't install empty /var/lock to avoid conflict with base-files
52 rm -rf ${D}${localstatedir}/lock
53}
54
55RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
56
57# The drbd items are explicitly put under /lib when installed.
58#
59FILES_${PN} += "/run"
60FILES_${PN} += "${nonarch_base_libdir}/drbd \
61 ${nonarch_libdir}/drbd \
62 ${nonarch_libdir}/tmpfiles.d"
63FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"