blob: 125b59e760853e8110d16dc799868a5bde02bb4f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Configure network interfaces for parallel routing"
2HOMEPAGE = "http://www.linuxfoundation.org/collaborate/workgroups/networking/bonding"
3SECTION = "net"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://debian/copyright;md5=acc89812938cf9ad6b1debc37cea0253"
7
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008inherit manpages
9MAN_PKG = "${PN}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11SRCREV = "42bfbb9beb924672ca86b86e9679ac3d6b87d992"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRC_URI = "git://salsa.debian.org/debian/ifenslave.git;protocol=https"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${S}/ifenslave ${D}${sbindir}/
19
20 install -m 0755 -D ${S}/debian/ifenslave.if-pre-up ${D}${sysconfdir}/network/if-pre-up.d/ifenslave
21 install -m 0755 -D ${S}/debian/ifenslave.if-post-down ${D}${sysconfdir}/network/if-post-down.d/ifenslave
22 install -m 0755 -D ${S}/debian/ifenslave.if-up ${D}${sysconfdir}/network/if-up.d/ifenslave
23 install -m 0644 -D ${S}/debian/ifenslave.8 ${D}${mandir}/man8/ifenslave.8
24}
25
26FILES_${PN}-doc_remove = "${mandir}"
27FILES_${PN} += "${mandir}/man8/ifenslave.8"