blob: 4df251c7f37f5776e64061c9f7b2721189e08bcc [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "libtalloc libtirpc"
7RDEPENDS_python-tevent = "python"
8
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
10 file://options-0.9.36.patch \
11 file://0001-libtevent-fix-musl-libc-compile-error.patch \
12"
13LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
14
15SRC_URI[md5sum] = "6859cd4081fdb2a76b1cb4bf1c803a59"
16SRC_URI[sha256sum] = "168345ed65eac03785cf77b95238e7dc66cbb473a42811693a6b0916e5dae7e0"
17
18inherit waf-samba
19
20PACKAGECONFIG ??= "\
21 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
23"
24PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
25PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
26PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
27PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
28PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
29PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
30
31SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
32
33S = "${WORKDIR}/tevent-${PV}"
34
35EXTRA_OECONF += "--disable-rpath \
36 --bundled-libraries=NONE \
37 --builtin-libraries=replace \
38 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
39 --without-gettext \
40 "
41
42PACKAGES += "python-tevent"
43
44RPROVIDES_${PN}-dbg += "python-tevent-dbg"
45
46FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"