blob: d2cafc9f6d49c64ea9b1a6802d72eba0ba3faed3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A high-performance memory object caching system"
2DESCRIPTION = "\
3 memcached optimizes specific high-load serving applications that are designed \
4 to take advantage of its versatile no-locking memory access system. Clients \
5 are available in several different programming languages, to suit the needs \
6 of the specific application. Traditionally this has been used in mod_perl \
7 apps to avoid storing large chunks of data in Apache memory, and to share \
8 this burden across several machines."
9SECTION = "web"
10HOMEPAGE = "http://memcached.org/"
11LICENSE = "BSD-3-Clause"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
14
15inherit autotools
16
17DEPENDS += "libevent"
18RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader \
19 perl-module-tie-hash bash \
20 "
21
22SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
23 file://memcached-add-hugetlbfs-check.patch \
24 "
25SRC_URI[md5sum] = "8462616b554183a75845b03c56837cca"
26SRC_URI[sha256sum] = "494c060dbd96d546c74ab85a3cc3984d009b4423767ac33e05dd2340c01f1c4b"
27
28# set the same COMPATIBLE_HOST as libhugetlbfs
29COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64|arm).*-linux'
30
31python __anonymous () {
32 endianness = d.getVar('SITEINFO_ENDIANNESS')
33 if endianness == 'le':
34 d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=little")
35 else:
36 d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=big")
37}
38
39PACKAGECONFIG ??= ""
40PACKAGECONFIG[hugetlbfs] = "--enable-hugetlbfs, --disable-hugetlbfs, libhugetlbfs"
41
42inherit update-rc.d
43
44INITSCRIPT_NAME = "memcached"
45INITSCRIPT_PARAMS = "defaults"
46
47do_install_append() {
48 install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
49 mkdir -p ${D}/usr/share/memcached/scripts
50 install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
51 install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
52}