blob: bb401666c63a48d41896044506b9441aabdef593 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001# This package builds tools to manage NIS
2# The source package is utils/net/NIS/yp-tools
3#
4require nis.inc
5
6SUMMARY = "NIS client programs"
7DESCRIPTION = " \
8Network Information Service tools. \
9This package contains ypcat, ypmatch, ypset, \
10ypwhich, yppasswd, domainname, nisdomainname \
11and ypdomainname. \
12"
13
14# v4.2.3
15SRCREV = "1bfda29c342a81b97cb1995ffd9e8da5de63e7ab"
16
17SRC_URI = "git://github.com/thkukuk/yp-tools \
18 file://domainname.service \
19 "
20
21S = "${WORKDIR}/git"
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023DEPENDS = "libtirpc libnsl2 virtual/crypt"
Brad Bishop316dfdd2018-06-25 12:45:53 -040024
25inherit autotools systemd
26SYSTEMD_SERVICE_${PN} = "domainname.service"
27
28RPROVIDES_${PN} += "${PN}-systemd"
29RREPLACES_${PN} += "${PN}-systemd"
30RCONFLICTS_${PN} += "${PN}-systemd"
31
32CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true"
33
34EXTRA_OECONF = " \
35 --disable-rpath --disable-domainname \
36 "
37CFLAGS_append_libc-musl = " -Wno-error=cpp"
38
39FILES_${PN} += " ${libdir}/yp-nis/*.so.*.* ${libdir}/yp-nis/pkgconfig/"
40FILES_${PN}-dbg += " ${libdir}/yp-nis/.debug"
41FILES_${PN}-dev += " ${libdir}/yp-nis/*.so ${libdir}/yp-nis/*.so.[12] ${libdir}/yp-nis/*.la"
42FILES_${PN}-staticdev += " ${libdir}/yp-nis/*.a"
43
44do_install_append() {
45 install -d ${D}${systemd_unitdir}/system
46 install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system
47}