blob: 9822f455ec2928c63bbd93f5c4c8e4ecb11e06c5 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# This package builds the NIS ypbind daemon
2# The source package is utils/net/NIS/ypbind-mt
3#
4require nis.inc
5
6DESCRIPTION = " \
7Multithreaded NIS bind service (ypbind-mt). \
8ypbind-mt is a complete new implementation of a NIS \
9binding daemon for Linux. It has the following \
10features. Supports ypbind protocol V1 and V2. \
11Uses threads for better response. Supports multiple \
12domain bindings. Supports /var/yp/binding/* file \
13for Linux libc 4/5 and glibc 2.x. Supports a list \
14of known secure NIS server (/etc/yp.conf) Binds to \
15the server which answered as first. \
16\
17This is the final IPv4-only version of ypbind-mt. \
18"
19HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
20DEPENDS = " \
21 yp-tools \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
23 "
24DEPENDS_append_libc-musl = " bsd-headers nss"
25RDEPENDS_${PN} += "yp-tools"
26
27# ypbind-mt now provides all the functionality of ypbind
28# and is used in place of it.
29PROVIDES += "ypbind"
30
31SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
32 file://ypbind.init \
33 file://ypbind.service \
34 file://0001-dns_hosts-Fix-build-with-musl.patch \
35 "
36SRC_URI[md5sum] = "1aeccd0d11c064d5d59c56941bca682b"
37SRC_URI[sha256sum] = "a2e1fa8fc992a12b289c229e00e38c20d59070c3bcf08babf40c692515c340e0"
38
39inherit systemd update-rc.d
40
41SYSTEMD_SERVICE_${PN} = "ypbind.service"
42INITSCRIPT_NAME = "ypbind"
43INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
44
45CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
46
47CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/nss3"
48
49do_install_append () {
50 install -d ${D}${sysconfdir}/init.d
51 install -d ${D}${sysconfdir}/rcS.d
52
53 install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
54
55 install -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
57}
58
59
60RPROVIDES_${PN} += "${PN}-systemd"
61RREPLACES_${PN} += "${PN}-systemd"
62RCONFLICTS_${PN} += "${PN}-systemd"