blob: d28ebd48450f2cf9446ae35b3e4fe36e19636c95 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "IPMI (Intelligent Platform Management Interface) library and tools"
2DESCRIPTION = "OpenIPMI is an effort to create a full-function IPMI system, \
3to allow full access to all IPMI information on a server \
4and to abstract it to a level that will make it easy to use"
5
6HOMEPAGE = "http://openipmi.sourceforge.net"
7
8DEPENDS = " \
9 glib-2.0 \
10 ncurses \
11 net-snmp \
12 openssl \
13 popt \
14 python \
15 swig-native \
16 "
17
18LICENSE = "GPLv2 & LGPLv2.1 & BSD"
19
20LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
21 file://COPYING.LIB;md5=d8045f3b8f929c1cb29a1e3fd737b499 \
22 file://COPYING.BSD;md5=4b318d4160eb69c8ee53452feb1b4cdf \
23 "
24
25SRC_URI = "${SOURCEFORGE_MIRROR}/openipmi/OpenIPMI-${PV}.tar.gz \
26 file://fix-symlink-install-error-in-cmdlang.patch \
27 file://openipmi-no-openipmigui-man.patch \
28 file://openipmi-remove-host-path-from-la_LDFLAGS.patch \
29 file://ipmi-init-fix-the-arguments.patch \
30 file://do-not-install-pyc-and-pyo.patch \
31 file://include_sys_types.patch \
32 file://openipmigui-not-compile-pyc-pyo.patch \
33 file://openipmi-helper \
34 file://ipmi.service \
35 "
36
37S = "${WORKDIR}/OpenIPMI-${PV}"
38SRC_URI[md5sum] = "1461ac4d78fc516646fd0a6e605a8b05"
39SRC_URI[sha256sum] = "f0f1a0ec732409930b7a31a6daa6cf39b585f52059b62a5f092b7ece21aa75a5"
40
41inherit autotools-brokensep pkgconfig pythonnative perlnative update-rc.d systemd
42
43EXTRA_OECONF = "--disable-static \
44 --with-perl='${STAGING_BINDIR_NATIVE}/perl-native/perl' \
45 --with-python='${STAGING_BINDIR_NATIVE}/python-native/python' \
46 --with-pythoninstall='${PYTHON_SITEPACKAGES_DIR}' \
47 --with-glibver=2.0"
48
49PACKAGECONFIG ??= "gdbm"
50PACKAGECONFIG[gdbm] = "ac_cv_header_gdbm_h=yes,ac_cv_header_gdbm_h=no,gdbm,"
51
52PACKAGES += "${PN}-perl ${PN}-python"
53
54FILES_${PN}-perl = " \
55 ${libdir}/perl/vendor_perl/*/OpenIPMI.pm \
56 ${libdir}/perl/vendor_perl/*/auto/OpenIPMI/OpenIPMI.so \
57 "
58
59FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
60
61FILES_${PN}-dbg += " \
62 ${libdir}/perl/vendor_perl/*/auto/OpenIPMI/.debug \
63 ${PYTHON_SITEPACKAGES_DIR}/.debug \
64 "
65
66do_configure () {
67
68 # Let's perform regular configuration first then handle perl issues.
69 autotools_do_configure
70
71 perl_ver=`perl -V:version | cut -d\' -f 2`
72
73 # Force openipmi perl bindings to be compiled using perl-native instead of
74 # the host's perl. Set the proper install directory for the resulting
75 # openipmi.pm and openipmi.so
76 for i in ${S}/swig/Makefile ${S}/swig/perl/Makefile; do
77 echo "SAL: i = $i"
78 echo "SAL: STAGING_INCDIR_NATIVE = $STAGING_INCDIR_NATIVE"
79 echo "SAL: libdir = $libdir"
80 sed -i -e "/^PERL_CFLAGS/s:-I/usr/local/include:-I${STAGING_INCDIR_NATIVE}:g" $i
81 sed -i -e "/^PERL_INSTALL_DIR/s:^PERL_INSTALL_DIR = .*:PERL_INSTALL_DIR = ${libdir}/perl/vendor_perl/$perl_ver:g" $i
82 done
83}
84
85do_install_append () {
86 echo "SAL: D = $D"
87 echo "SAL: libdir = $libdir"
88 install -m 0755 -d ${D}${sysconfdir}/sysconfig ${D}${sysconfdir}/init.d
89 install -m 0755 ${S}/ipmi.init ${D}${sysconfdir}/init.d/ipmi
90 install -m 0644 ${S}/ipmi.sysconf ${D}${sysconfdir}/sysconfig/ipmi
91 # SAL: mv: cannot stat `/localdisk/loadbuild/slittle1/workspace/cgts_test_build/bitbake_build/tmp/work/x86_64-wrs-linux/openipmi-2.0.19-r4/image/usr/lib64/perl5': No such file or directory
92 # SAL: real path to perl is /localdisk/loadbuild/slittle1/workspace/cgts_test_build/bitbake_build/tmp/work/x86_64-wrs-linux/perl-5.14.2-r8.3/package/usr/lib64/perl5 and it is a symlink to perl so no need to mv.
93 if [ -d ${D}${libdir}/perl5 ]
94 then
95 mv ${D}${libdir}/perl5 ${D}${libdir}/perl
96 fi
97
98 # for systemd
99 install -d ${D}${systemd_unitdir}/system
100 install -m 0664 ${WORKDIR}/ipmi.service ${D}${systemd_unitdir}/system
101 sed -i -e "s,@LIBEXECDIR@,${libexecdir},g" ${D}${systemd_unitdir}/system/ipmi.service
102 install -d ${D}${libexecdir}
103 install -m 0755 ${WORKDIR}/openipmi-helper ${D}${libexecdir}
104}
105
106INITSCRIPT_NAME = "ipmi"
107INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
108
109SYSTEMD_SERVICE_${PN} = "ipmi.service"
110SYSTEMD_AUTO_ENABLE = "disable"