blob: 6ad864d1e86a799d49f5d627221d649ae3b0ff3a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Userspace support for InfiniBand/RDMA verbs"
2DESCRIPTION = "This is the userspace components for the Linux Kernel's drivers Infiniband/RDMA subsystem."
3SECTION = "libs"
4
5DEPENDS = "libnl"
6RDEPENDS_${PN} = "bash perl"
7
8SRC_URI = "git://github.com/linux-rdma/rdma-core.git;branch=stable-v18 \
9 file://0001-S_IFSOCK-is-defined-in-both-glibc-musl.patch \
10 file://0002-neigh.c-Do-not-include-net-if_packet.h.patch \
11 file://0001-include-endian.h-for-htole32-and-friends.patch \
12 file://0002-Remove-unused-include-for-execinfo.h.patch \
13 file://0001-Remove-man-files-which-cant-be-built.patch \
14 "
15SRCREV = "7844b3fbe5120623d63b29ecb43eb83a61129658"
16S = "${WORKDIR}/git"
17
18#Default Dual License https://github.com/linux-rdma/rdma-core/blob/master/COPYING.md
19LICENSE = "BSD-2-Clause | GPLv2"
20LIC_FILES_CHKSUM = "file://COPYING.BSD_FB;md5=0ec18bae1a9df92c8d6ae01f94a289ae \
21 file://COPYING.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263"
22
23
24FILES_SOLIBSDEV = ""
25FILES_${PN} += "${libdir}/*"
26INSANE_SKIP_${PN} += "dev-so"
27
28inherit cmake
29
30OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"