blob: 1ad46c2c3103e019e5741d026bd29ad490d95512 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
13LICENSE = "BSD & LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
16PV = "0.14.1+git${SRCPV}"
17
18SRCREV_spice = "eaa07ef15cfc3bf57a69da2576af66f028787774"
19SRCREV_spice-common = "6b93b3fce8909b836ef1d1434d191900d8aa00be"
20
21SRCREV_FORMAT = "spice_spice-common"
22
23SRC_URI = " \
24 git://anongit.freedesktop.org/spice/spice;name=spice \
25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \
26 file://0001-Convert-pthread_t-to-be-numeric.patch \
27 file://0001-spice-fix-compile-fail-problem.patch \
28"
29
30S = "${WORKDIR}/git"
31
32inherit autotools gettext pythonnative python-dir pkgconfig
33
34DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python-pyparsing-native python-six-native glib-2.0-native"
35DEPENDS_append_class-nativesdk = "nativesdk-openssl"
36
37export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
38export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
39
40PACKAGECONFIG_class-native = ""
41PACKAGECONFIG_class-nativesdk = ""
42PACKAGECONFIG ?= "sasl"
43
44PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
45PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
46PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
47PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
48PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
49PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
50PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
51PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
52
53COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
54
55BBCLASSEXTEND = "native nativesdk"
56
57EXTRA_OECONF_toolchain-clang += "--disable-werror"