blob: eca77cf84983a5c802f5081d30309e69b03db206 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Program for providing universal TLS/SSL tunneling service"
2DESCRIPTION = "SSL encryption wrapper between remote client and local (inetd-startable) or remote server."
3HOMEPAGE = "https://www.stunnel.org/"
4SECTION = "net"
5# Note: Linking stunnel statically or dynamically with other modules is making
6# a combined work based on stunnel. Thus, the terms and conditions of the GNU
7# General Public License cover the whole combination.
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=f6b7fe7379c9c2d7db6c80f7bd41e06d"
10
11DEPENDS = "autoconf-archive libnsl2 openssl"
12
13SRC_URI = "ftp://ftp.stunnel.org/stunnel/archive/5.x/${BP}.tar.gz \
14 file://fix-openssl-no-des.patch \
15"
16
17SRC_URI[md5sum] = "0b41240e5585ec7d55ca343feed5530f"
18SRC_URI[sha256sum] = "3d6641213a82175c19f23fde1c3d1c841738385289eb7ca1554f4a58b96d955e"
19
20inherit autotools
21
22PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} libwrap"
23
24PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
25PACKAGECONFIG[libwrap] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
26PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
27
28EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
29
30# When cross compiling, configure defaults to nobody, but provides no option to change it.
31EXTRA_OEMAKE += "DEFAULT_GROUP='nogroup'"
32
33# stunnel3 is a Perl wrapper to allow use of the legacy stunnel 3.x commandline
34# syntax with stunnel >= 4.05
35PACKAGES =+ "stunnel3"
36FILES_stunnel3 = "${bindir}/stunnel3"
37RDEPENDS_stunnel3 += "${PN} perl"