blob: 144dcf33ac458a979b747e62b9626c4f93355c4e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Lightweight http(s) proxy daemon"
2HOMEPAGE = "https://tinyproxy.github.io/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.gz \
7 file://disable-documentation.patch \
8 file://tinyproxy.service"
9
10SRC_URI[md5sum] = "423047c8dc53a15e19f78e238198549c"
11SRC_URI[sha256sum] = "6020955e6a0ef0ef898ad5bb17a448c47f9e4c003c464b4ae7c4dba063272055"
12
13EXTRA_OECONF += " \
14 --enable-filter \
15 --enable-transparent \
16 --enable-reverse \
17 --enable-upstream \
18 --enable-xtinyproxy \
19 "
20
21inherit autotools systemd useradd
22
23#User specific
24USERADD_PACKAGES = "${PN}"
25USERADD_PARAM_${PN} = "--system --home /dev/null \
26 --no-user-group --gid nogroup tinypoxy"
27
28SYSTEMD_PACKAGES += "${BPN}"
29SYSTEMD_SERVICE_${PN} = "tinyproxy.service"
30SYSTEMD_AUTO_ENABLE_${PN} = "enable"
31
32do_install_append() {
33 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
34 install -d ${D}${systemd_system_unitdir}
35 install -m 0644 ${WORKDIR}/tinyproxy.service ${D}${systemd_system_unitdir}
36 fi
37}