blob: 4e11d8233cfd49cff09aa46e665853b1ac1b6ca3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Network benchmark tool"
2DESCRIPTION = "\
3iperf is a tool for active measurements of the maximum achievable bandwidth \
4on IP networks. It supports tuning of various parameters related to timing, \
5protocols, and buffers. For each test it reports the bandwidth, loss, and \
6other parameters."
7HOMEPAGE = "http://software.es.net/iperf/"
8SECTION = "console/network"
9BUGTRACKER = "https://github.com/esnet/iperf/issues"
10AUTHOR = "ESNET <info@es.net>, Lawrence Berkeley National Laboratory <websupport@lbl.gov>"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=a9a036136b748453e839c0eb8906ef2e"
13
14DEPENDS = "openssl"
15
16SRC_URI = "git://github.com/esnet/iperf.git \
17 file://automake-foreign.patch \
18 file://0002-Remove-pg-from-profile_CFLAGS.patch \
19 "
20
21SRCREV = "88f3ad87f38762081a6d7127890ff5c3a052b06a"
22
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
28
29CFLAGS += "-D_GNU_SOURCE"
30
31EXTRA_OECONF = "--with-openssl=${RECIPE_SYSROOT}${prefix}"
32
33BBCLASSEXTEND = "native"