blob: b1fa51bf0366f9ef67ac6ee1ed9cc7a4888d1bc6 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
9SRC_URI[md5sum] = "3dc3a0e490e909f188379a9e05fd4780"
10SRC_URI[sha256sum] = "6306549109c7254baf31edb385265b19557b5692217d2dfcf96f6fb17de8e842"
11
12S = "${WORKDIR}/phoronix-test-suite"
13
14inherit systemd allarch
15
16do_install() {
17 DESTDIR=${D} ./install-sh ${exec_prefix}
18
19 if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
20 install -d ${D}/${systemd_unitdir}/system/
21 mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
22 rm -rf ${D}/usr/lib/
23 fi
24}
25
26# It is not advisable to enable these services by default since they can cause
27# continual target reboots if they encounter network problems.
28#
29SYSTEMD_AUTO_ENABLE = "disable"
30SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
31
32RDEPENDS_${PN} += "bash python php-cli util-linux-lscpu os-release lsb"
33
34FILES_${PN} += " \
35 ${datadir}/phoronix-test-suite \
36 ${datadir}/appdata/phoronix-test-suite.appdata.xml \
37 ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
38 ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
39 ${datadir}/mime/packages/openbenchmarking-mime.xml \
40 ${systemd_unitdir}/* \
41"