blob: 77d1728140658b1e2f001c46b177b82c9672a61b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Small collection of benchmarks for storage I/O"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b529aaa6a0c50f15d29f89609b5c22f3"
4
5SRCREV = "79698f645bfb28d0d966484ddad3a1efb562246d"
6PV = "0.0+git${SRCPV}"
7SRC_URI = "git://github.com/Algodev-github/S.git;protocol=https;branch=master"
8
9S = "${WORKDIR}/git"
10
11# installing in /opt/S-suite since the package has
12# dependencies to the directory structure.
13do_install() {
14 install -d ${D}/opt/S-suite
15 for i in $(find ${S}/* -type d); do
16 install -d ${D}/opt/S-suite/$(basename $i)
17 install -m0755 -p ${S}/$(basename $i)/* ${D}/opt/S-suite/$(basename $i)
18 done
19
20 install -m0755 ${S}/config_params.sh ${D}/opt/S-suite
21 install -m0755 ${S}/def_config_params.sh ${D}/opt/S-suite
22}
23
24RDEPENDS_${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat"
25
26FILES_${PN} = "/opt/S-suite/"
27
28# added to INSANE_SKIP since s-suite have an runtime
29# dependency (RDEPENDS) on libaio-dev.
30INSANE_SKIP_${PN} += "dev-deps"