blob: 20588ee974a7c174d80f05f70970399e2e63f4e2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhinstaller/efivar"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8DEPENDS = "popt"
9DEPENDS_append_class-target = " efivar-native"
10
11inherit pkgconfig
12
13COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
14
15SRCREV = "ef3449223ecd1e7b1098c523d66b2f960fe839ea"
16SRC_URI = "git://github.com/rhinstaller/efivar.git \
17 file://allow-multi-definitions-for-native.patch \
18 "
19SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'file://0004-fix-unknow-option-for-gold-linker.patch', '', d)} \
21 "
22SRC_URI_append_class-native = " file://fix-compile-failure-with-host-gcc-4.6.patch \
23 "
24
25S = "${WORKDIR}/git"
26
27do_compile_prepend() {
28 sed -i -e s:-Werror::g ${S}/gcc.specs
29}
30
31do_compile_class-native() {
32 oe_runmake -C src makeguids CC_FOR_BUILD="${BUILD_CC}"
33}
34
35do_install() {
36 oe_runmake install DESTDIR=${D}
37}
38
39do_install_class-native() {
40 install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids
41}
42
43BBCLASSEXTEND = "native"