blob: 9b7e6cd4de42352520fb10a2fb913fa85eb4f71c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "NVMe management command line interface"
2AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
3HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
4SECTION = "console/utils"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
7DEPENDS = "util-linux"
8PV .= "+git${SRCPV}"
9
10SRC_URI = "git://github.com/linux-nvme/nvme-cli.git \
11 file://0001-Makefile-fix-bash-completion-install-path.patch \
12 "
13SRCREV = "642d426faf8a67ed01e90f7c35c0d967f8cc52a3"
14
15S = "${WORKDIR}/git"
16
17inherit bash-completion
18
19do_install() {
20 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
21}