blob: a11ff9d2c4c4de704d9dee43994e48e1663445be [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3BUGTRACKER = "https://github.com/libuv/libuv/issues"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a68902a430e32200263d182d44924d47"
6
7S = "${WORKDIR}/git"
8SRCREV = "8cfd67e59195251dff793ee47c185c9d6a8f3818"
9BRANCH = "v1.x"
10SRC_URI = "git://github.com/libuv/libuv.git;protocol=https;branch=${BRANCH};"
11
12inherit autotools
13
14do_configure() {
15 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
16 oe_runconf
17}
18
19BBCLASSEXTEND = "native"