blob: 9bb81c4096a5d26336d9d20a709eb8c379cd5226 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Torrent client"
2HOMEPAGE = "http://libtorrent.rakshasa.no/"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6DEPENDS = "libsigc++-2.0 curl cppunit libtorrent ncurses"
7
8SRC_URI = "git://github.com/rakshasa/rtorrent \
9 file://don-t-run-code-while-configuring-package.patch \
10"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011# v0.9.7
12SRCREV = "327164f9d86aafcd2500a317d485374df32ea622"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014PV = "0.9.7+git${SRCPV}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16S = "${WORKDIR}/git"
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
19
20PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
21
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022inherit autotools pkgconfig
23
24do_configure_prepend() {
25 (cd ${S}; ./autogen.sh; cd -)
26}