blob: 51542081750a5d5ed998b322107ee6cde5357e90 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
2DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
3
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
6
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007inherit pkgconfig
8
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009DEPENDS = "wvstreams"
10RDEPENDS_${PN} = "ppp"
11
12SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \
13 file://typo_pon.wvdial.1.patch \
14 "
15
16SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
17SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
18
19EXTRA_OEMAKE = ""
20export WVLINK="${LD}"
21
22PARALLEL_MAKE = ""
23
24BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams"
25
26do_configure() {
27 sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
28}
29
30do_install() {
31 oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
32}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033# http://errors.yoctoproject.org/Errors/Details/186959/
34EXCLUDE_FROM_WORLD_libc-musl = "1"