blob: 048f166fcd94b26273389f0abb29c554fbaab747 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
10
11inherit autotools-brokensep pkgconfig module-base bash-completion systemd
12
13# v62
14SRCREV = "11f560f4048c1d38b7011a49566871a1e8a07c94"
15SRC_URI = "git://github.com/pmem/ndctl.git"
16
17DEPENDS = "virtual/kernel kmod udev json-c"
18
19PV = "v62+git${SRCPV}"
20S = "${WORKDIR}/git"
21
22EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
23
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[systemd] = "--with-systemd-unit-dir=${systemd_system_unitdir}, --without-systemd-unit-dir,"
26
27do_configure_prepend() {
28 ${S}/autogen.sh
29}
30
31SYSTEMD_SERVICE_${PN} = "ndctl-monitor.service"
32
33COMPATIBLE_HOST='(x86_64).*'