blob: 271f2eaa3cd73ea7a33a947dac2b7b0ded70f80c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A library for using PKCS"
2DESCRIPTION = "pkcs11-helper is a library that simplifies the interaction with PKCS \
3providers for end-user applications using a simple API and optional OpenSSL \
4engine. The library allows using multiple PKCS enumerating available token \
5certificates, or selecting a certificate directly by serialized id, handling \
6card removal and card insert events, handling card ie-insert to a different \
7slot, supporting session expiration and much more all using a simple API."
8
9HOMEPAGE = "http://www.opensc-project.org/pkcs11-helper/"
10SECTION = "Development/Libraries"
11
12LICENSE = "GPLv2 & BSD"
13LIC_FILES_CHKSUM = " \
14 file://COPYING;md5=30f10d22cfb1ba98ccd714a41ad3311a \
15 file://COPYING.GPL;md5=8a71d0475d08eee76d8b6d0c6dbec543 \
16 file://COPYING.BSD;md5=66b7a37c3c10483c1fd86007726104d7 \
17"
18SRC_URI = "git://github.com/OpenSC/${BPN}.git"
19
20S = "${WORKDIR}/git"
21# v1.25.1
22SRCREV = "2713cb09dcd90104cb7bceb5f14cd6f90834f7b1"
23
24DEPENDS = "zlib nettle gnutls gmp openssl nss nspr"
25
26inherit autotools pkgconfig
27
28EXTRA_OECONF = "--disable-static"