blob: 533a00026ec1d62d4799055ba5acfc661a956593 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
10 "
11SRC_URI[md5sum] = "b3b4e44ef49575043a91def0207dcc76"
12SRC_URI[sha256sum] = "967823be36f23cbc972eb0aa882d069c1d155a5978990ac3bcf425e6a2e7ff9a"
13
14COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
15
16# The install rule from the Makefile has hardcoded paths, so we duplicate
17# the actions to accommodate different paths.
18do_install () {
19 install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
20 install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
21}