blob: d6e42c81d53bd58477b9c8487ef768cba8f2c491 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit."
2DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \
3It is written using the Boost Spirit parser generator. If you are \
4already using Boost, you can use JSON Spirit without any additional \
5dependencies."
6HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx"
7SECTION = "libs"
8PRIORITY = "optional"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9"
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012DEPENDS = "boost"
13
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014SRC_URI = "file://json_spirit_v${PV}.zip \
15 file://0001-Adjust-the-cmake-files.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016 file://0001-Link-to-libatomic.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017"
18
19S = "${WORKDIR}/json_spirit_v${PV}"
20
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021inherit cmake
22
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023BBCLASSEXTEND = "nativesdk"