blob: de9a6eb99852be5602fb03f9ec25bc09c2bffbc6 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014DEPENDS += "ncurses flex bison gperf-native bison-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015RDEPENDS_${PN} += "python3 bash"
16SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends;branch=4.11.x \
17 file://0001-Makefile-ensure-frontends-exits-before-writing-into-.patch \
18 file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
19
20SRCREV = "f22fce3a308be1c7790ebefc6bbedb33c5f7c86a"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig
25do_configure_prepend () {
26 mkdir -p ${S}/scripts/.autostuff/m4
27}
28
29do_install_append() {
30 ln -s kconfig-conf ${D}${bindir}/conf
31 ln -s kconfig-mconf ${D}${bindir}/mconf
32}
33
34EXTRA_OECONF += "--disable-gconf --disable-qconf"
35
36# Some packages have the version preceeding the .so instead properly
37# versioned .so.<version>, so we need to reorder and repackage.
38SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
39FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
40
41BBCLASSEXTEND = "native"