blob: 7544744b34b89336a68c6350334e2a81d6f4d5c7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linear Algebra PACKage"
2URL = "http://www.netlib.org/lapack"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=930f8aa500a47c7dab0f8efb5a1c9a40"
5
6# Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended)
7# Enabling FORTRAN
8# Note this is not officially supported and is just illustrated here to
9# show an example of how it can be done
10# You'll also need your fortran recipe to depend on libgfortran
11#FORTRAN_forcevariable = ",fortran"
12#RUNTIMETARGET_append_pn-gcc-runtime = " libquadmath"
13
14DEPENDS = "libgfortran"
15
16SRC_URI = "http://www.netlib.org/lapack/lapack-${PV}.tar.gz"
17SRC_URI[md5sum] = "96591affdbf58c450d45c1daa540dbd2"
18SRC_URI[sha256sum] = "deb22cc4a6120bff72621155a9917f485f96ef8319ac074a7afbc68aab88bcf6"
19
20EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON "
21OECMAKE_GENERATOR = "Unix Makefiles"
22
23inherit cmake pkgconfig
24EXCLUDE_FROM_WORLD = "1"