blob: b344fbf3265169c497ffdc5fcf587a171e2c25db [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small tool to provide detailed information on the hardware \
2configuration of the machine. It can report exact memory configuration, \
3firmware version, mainboard configuration, CPU version and speed, cache \
4configuration, bus speed, etc. on DMI-capable or EFI systems."
5SUMMARY = "Hardware lister"
6HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
7SECTION = "console/tools"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
13
14SRC_URI = " \
15 http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
16 file://0001-Makefile-Fix-cross-compilation.patch \
17 file://0002-Makefile-Use-supplied-LDFLAGS-to-silence-OE-GNU_HASH.patch \
18 file://0003-sysfs-Fix-basename-build-with-musl.patch \
19"
20SRC_URI[md5sum] = "8671c6d94d6324a744b7f21f1bfecfd2"
21SRC_URI[sha256sum] = "ae22ef11c934364be4fd2a0a1a7aadf4495a0251ec6979da280d342a89ca3c2f"
22
23S = "${WORKDIR}/lshw-B.${PV}"
24
25do_compile() {
26 # build core only - don't ship gui
27 oe_runmake -C src core
28}
29
30do_install() {
31 oe_runmake install DESTDIR=${D}
32}