blob: 13710aaea3cc4770a015ef0cdfd2a85da72eeafe [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The Mercurial distributed SCM"
2HOMEPAGE = "http://mercurial.selenic.com/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6DEPENDS = "python python-native"
7DEPENDS_class-native = "python-native"
8RDEPENDS_${PN} = "python python-modules"
9
10inherit python-dir
11
12SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz"
13SRC_URI[md5sum] = "f9b2e4a3b5901ef744fa3abe4196e97e"
14SRC_URI[sha256sum] = "89fa8ecbc8aa6e48e98f9803a1683ba91367124295dba2407b28c34ca621108d"
15
16S = "${WORKDIR}/mercurial-${PV}"
17
18BBCLASSEXTEND = "native"
19
20EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
21 PREFIX=${prefix}"
22
23do_configure_append () {
24 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
25}
26
27do_install () {
28 oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
29}
30
31FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"