blob: c812ae137492616afdec1c985f62afbcd881dc4a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "\
2IPC::Run allows you run and interact with child processes \
3using files, pipes, and pseudo-ttys. Both system()-style and scripted \
4usages are supported and may be mixed. Likewise, functional and OO API \
5styles are both supported and may be mixed."
6HOMEPAGE = "https://metacpan.org/release/IPC-Run"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
10DEPENDS = "perl"
11
12SRC_URI = "git://github.com/toddr/IPC-Run.git"
13SRCREV = "0b409702490729eeb97ae65f5b94d949ec083134"
14
15S = "${WORKDIR}/git"
16
17inherit cpan
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}