blob: 7ef03009258badf5490e66e9024706ad3c816dc4 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558"
12
13DEPENDS = "protobuf-native protobuf"
14
15PV .= "+git${SRCPV}"
16SRCREV = "269771b4b45d3aba04e59569f53600003db8d9ff"
17
18SRC_URI = "git://github.com/protobuf-c/protobuf-c.git"
19
20S = "${WORKDIR}/git"
21
22#make sure c++11 is used
23CXXFLAGS += "-std=c++11"
24BUILD_CXXFLAGS += "-std=c++11"
25
26inherit autotools pkgconfig
27
28PACKAGE_BEFORE_PN = "${PN}-compiler"
29
30FILES_${PN}-compiler = "${bindir}"
31
32RDEPENDS_${PN}-compiler = "protobuf-compiler"
33RDEPENDS_${PN}-dev += "${PN}-compiler"
34
35BBCLASSEXTEND = "native nativesdk"