blob: c90eab043b8b1f5c9978c25cdc6161254ff41b2b [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A fast JSON parser/generator for C++ with both SAX/DOM style API"
2HOMEPAGE = "http://rapidjson.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://license.txt;md5=ba04aa8f65de1396a7e59d1d746c2125"
6
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007SRC_URI = "git://github.com/miloyip/rapidjson.git;nobranch=1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRCREV = "6a905f9311f82d306da77bd963ec5aa5da07da9c"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
11PV = "1.1.0+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE += "-DRAPIDJSON_BUILD_DOC=OFF -DRAPIDJSON_BUILD_TESTS=OFF -DRAPIDJSON_BUILD_EXAMPLES=OFF"
18
19# RapidJSON is a header-only C++ library, so the main package will be empty.
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021ALLOW_EMPTY_${PN} = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022
23BBCLASSEXTEND = "native nativesdk"