blob: ca38e6aa2114898d6296b0ce7db3500dc6ab8216 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Trace and analyze execution of a program written in C/C++"
2HOMEPAGE = "https://github.com/namhyung/uftrace"
3BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "elfutils"
9DEPENDS_append_libc-musl = " argp-standalone"
10
11inherit autotools
12
13# v0.8.3
14SRCREV = "8b723a6fae2ef30495cd6279774fba9c95cd9c88"
15SRC_URI = "git://github.com/namhyung/${BPN} \
16 file://0001-include-dlfcn.h-for-RTLD_DEFAULT.patch \
17 "
18S = "${WORKDIR}/git"
19
20LDFLAGS_append_libc-musl = " -largp"
21
22def set_target_arch(d):
23 import re
24 arch = d.getVar('TARGET_ARCH', True)
25 if re.match(r'i.86', arch, re.I):
26 return 'i386'
27 else:
28 return arch
29
30EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
31 with_elfutils=/use/libelf/from/sysroot"
32
33do_configure() {
34 ${S}/configure ${EXTRA_UFTRACE_OECONF}
35}
36
37FILES_SOLIBSDEV = ""
38FILES_${PN} += "${libdir}/*.so"
39
40COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
41
42# uftrace supports armv6 and above
43COMPATIBLE_HOST_armv4 = 'null'
44COMPATIBLE_HOST_armv5 = 'null'