blob: 9d0123d8bd637869503efeae7b7ce96a48ca2533 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2014 - 2017 Wind River Systems, Inc.
3#
4SUMMARY = "CFEngine is an IT infrastructure automation framework"
5
6DESCRIPTION = "CFEngine is an IT infrastructure automation framework \
7that helps engineers, system administrators and other stakeholders \
8in an IT system to manage and understand IT infrastructure throughout \
9its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit."
10
11HOMEPAGE = "http://cfengine.com"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=f8b34828ab373d6b1bb4b0fc60a78494"
15
16DEPENDS = "attr tokyocabinet"
17
18SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \
19 file://set-path-of-default-config-file.patch \
20 "
21
22SRC_URI[md5sum] = "33ef12260db4b430352229f37f7cb0e5"
23SRC_URI[sha256sum] = "d71ba98a272390c6fa8bc20e8ea27f0050a0a72a3e6b206a4762b4646be332ec"
24
25inherit autotools systemd
26
27export EXPLICIT_VERSION="${PV}"
28
29SYSTEMD_SERVICE_${PN} = "cfengine3.service cf-apache.service cf-hub.service cf-postgres.service \
30 cf-runalerts.service cf-execd.service \
31 cf-monitord.service cf-serverd.service \
32"
33SYSTEMD_AUTO_ENABLE_${PN} = "disable"
34
35PACKAGECONFIG ??= "libpcre openssl \
36 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \
37"
38PACKAGECONFIG[libxml2] = "--with-libxml2=yes,--with-libxml2=no,libxml2,"
39PACKAGECONFIG[mysql] = "--with-mysql=yes,--with-mysql=no,mysql,"
40PACKAGECONFIG[postgresql] = "--with-postgresql=yes,--with-postgresql=no,postgresql,"
41PACKAGECONFIG[acl] = "--with-libacl=yes,--with-libacl=no,acl,"
42PACKAGECONFIG[libvirt] = "--with-libvirt=yes,--with-libvirt=no,libvirt,"
43PACKAGECONFIG[libpcre] = "--with-pcre=yes,--with-pcre=no,libpcre,"
44PACKAGECONFIG[openssl] = "--with-openssl=yes,--with-openssl=no,openssl,"
45PACKAGECONFIG[pam] = "--with-pam=yes,--with-pam=no,libpam,"
46PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml,"
47PACKAGECONFIG[systemd] = "--with-systemd-service=${systemd_system_unitdir},--without-systemd-service"
48PACKAGECONFIG[libcurl] = "--with-libcurl,--without-libcurl,curl,"
49
50EXTRA_OECONF = "hw_cv_func_va_copy=yes --with-init-script=${sysconfdir}/init.d --with-tokyocabinet"
51
52do_install_append() {
53 install -d ${D}${localstatedir}/${BPN}/bin
54 for f in `ls ${D}${bindir}`; do
55 ln -s ${bindir}/`basename $f` ${D}${localstatedir}/${BPN}/bin/
56 done
57
58 install -d ${D}${sysconfdir}/default
59 cat << EOF > ${D}${sysconfdir}/default/cfengine3
60RUN_CF_SERVERD=1
61RUN_CF_EXECD=1
62RUN_CF_MONITORD=1
63RUN_CF_HUB=0
64EOF
65
66 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
67 install -m 0755 -D ${D}${sysconfdir}/init.d/cfengine3 ${D}${datadir}/${BPN}/cfengine3
68 sed -i -e 's#/etc/init.d#${datadir}/${BPN}#' ${D}${systemd_system_unitdir}/*.service
69 fi
70}
71
72RDEPENDS_${PN} += "${BPN}-masterfiles"