blob: f9fd8ae88e0ddb282bd3fb0367bbe619d438d009 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Gnuplot is a portable command-line driven graphing utility"
2DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
3(text or binary) and function plotting utility."
4HOMEPAGE = "http://www.gnuplot.info/"
5SECTION = "console/scientific"
6LICENSE = "gnuplot"
7LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
8DEPENDS = "${BPN}-native virtual/libx11 gd readline"
9
10inherit autotools distro_features_check
11# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${BP}.tar.gz;name=archive \
15 http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
16 file://gnuplot.desktop \
17 file://gnuplot.png \
18"
19SRC_URI_append_class-target = " \
20 file://0002-do-not-build-demos.patch \
21 file://0003-Use-native-tools-to-build-docs.patch \
22 file://0004-Add-configure-option-to-find-qt5-native-tools.patch \
23"
24
25SRC_URI[archive.md5sum] = "60aedd08998160593199459dea8467fe"
26SRC_URI[archive.sha256sum] = "a416d22f02bdf3873ef82c5eb7f8e94146795811ef808e12b035ada88ef7b1a1"
27SRC_URI[qtplot.md5sum] = "0a481885a496092c77eb4017540b5cf6"
28SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"
29
30# for building docs (they deserve it) we need *doc2* tools native
31BBCLASSEXTEND = "native"
32DEPENDS_class-native = "readline-native"
33PACKAGECONFIG_class-native = ""
34
35SRC_URI_append_class-native = "file://0001-reduce-build-to-conversion-tools-for-native-build.patch"
36
37do_install_class-native() {
38 install -d ${D}${bindir}
39 install ${B}/docs/*doc* ${D}${bindir}
40 rm ${D}${bindir}/*.o
41}
42
43PACKAGECONFIG ??= "cairo"
44PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
45PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
46PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native"
47
48EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
49 --without-tutorial \
50 --disable-wxwidgets"
51
52do_compile_prepend() {
53 install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
54}
55
56do_install_append_class-target() {
57 install -d ${D}${datadir}/applications/
58 install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
59 install -d ${D}${datadir}/pixmaps/
60 install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
61}
62
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080063PACKAGES =+ "${PN}-x11"
64
65RPROVIDES_${PN}-dbg += "${PN}-x11-dbg"
66
Brad Bishop316dfdd2018-06-25 12:45:53 -040067DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
68SECTION_${PN}-x11 = "x11/scientific"
69FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
70
71FILES_${PN} += "${datadir}/texmf"