blob: bf1367391b3ad659457f014613260d913a29bb49 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "haveged - A simple entropy daemon"
2DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
3AUTHOR = "Gary Wuertz"
4HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "http://www.issihosts.com/haveged/haveged-${PV}.tar.gz \
9 file://haveged-init.d-Makefile.am-add-missing-dependency.patch \
10"
11
12SRC_URI[md5sum] = "fb1d8b3dcbb9d06b30eccd8aa500fd31"
13SRC_URI[sha256sum] = "f77d9adbdf421b61601fa29faa9ce3b479d910f73c66b9e364ba8642ccbfbe70"
14
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015UPSTREAM_CHECK_URI = "http://www.issihosts.com/haveged/downloads.html"
16
Brad Bishop316dfdd2018-06-25 12:45:53 -040017inherit autotools update-rc.d systemd
18
19EXTRA_OECONF = "\
20 --enable-nistest=yes \
21 --enable-olt=yes \
22 --enable-threads=no \
23"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
26PACKAGECONFIG[systemd] = "--enable-init=service.redhat --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd"
27
28INITSCRIPT_PACKAGES = "${PN}"
29INITSCRIPT_NAME = "haveged"
30INITSCRIPT_PARAMS_${PN} = "defaults 9"
31
32SYSTEMD_PACKAGES = "${PN}"
33SYSTEMD_SERVICE_${PN} = "haveged.service"
34
35do_install_append() {
36 # The exit status is 143 when the service is stopped
37 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service
39 fi
40}
41
42MIPS_INSTRUCTION_SET = "mips"