blob: 5f4155ea56b4a4c7e58386f8ea429d1b2b80dfaf [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Portable Hardware Locality (hwloc) software package"
2DESCRIPTION = "The Portable Hardware Locality (hwloc) software package \
3 provides a portable abstraction of the hierarchical topology of modern \
4 architectures."
5HOMEPAGE = "https://www.open-mpi.org/software/hwloc/"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=3282e20dc3cec311deda3c6d4b1f990b"
9
10SRC_URI = "https://www.open-mpi.org/software/${BPN}/v1.11/downloads/${BP}.tar.bz2"
11SRC_URI[md5sum] = "0981a01935982aa7e850a96e0c3057b0"
12SRC_URI[sha256sum] = "2be808383d8337846fe77ce49c7ad3336fb6857505494d85c0ac03f22c5bd1e7"
13
14UPSTREAM_CHECK_URI = "https://www.open-mpi.org/software/hwloc/v1.11/"
15
16inherit autotools pkgconfig
17
18DEPENDS += "ncurses udev zlib"
19DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}"
20
21PACKAGECONFIG ?= "pci libxml2 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
22
23PACKAGECONFIG[numactl] = "--enable-libnuma,--disable-libnuma,numactl,numactl"
24PACKAGECONFIG[libxml2] = "--enable-libxml2,--disable-libxml2,libxml2,libxml2"
25PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo"
26PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess"
27
28# Split hwloc library into separate subpackage
29PACKAGES_prepend = " libhwloc "
30FILES_libhwloc += "${libdir}/libhwloc.so.*"
31RDEPENDS_${PN} += "libhwloc (= ${EXTENDPKGV})"