blob: bb59845196e4d6f612619fac29622879aa2cd3d5 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "An easy to use logging library"
2DESCRIPTION = " \
3liblogging (the upstream project) is a collection of several components. \
4Namely: stdlog, journalemu, rfc3195. \
5The stdlog component of liblogging can be viewed as an enhanced version of \
6the syslog(3) API. It retains the easy semantics, but makes the API more \
7sophisticated "behind the scenes" with better support for multiple threads \
8and flexibility for different log destinations (e.g. syslog and systemd \
9journal)."
10SECTION = "libs"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=63fe03535d83726f5655072502bef1bc"
13SRC_URI = "http://download.rsyslog.com/${BPN}/${BPN}-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "f215c7e7ac6cfd1f5dabdba08c522b29"
16SRC_URI[sha256sum] = "338c6174e5c8652eaa34f956be3451f7491a4416ab489aef63151f802b00bf93"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF = "--disable-man-pages"
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
23PACKAGECONFIG[systemd] = "--enable-journal, --disable-journal, systemd"