blob: 542956cf685b45650bf4513608492c10908a6478 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "Libraries providing API for reporting different problems in applications \
2to different bug targets like Bugzilla, ftp, trac, etc..."
3SUMMARY = "Generic library for reporting various problems"
4HOMEPAGE = "https://abrt.readthedocs.org/"
5LICENSE = "GPLv2+"
6DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
7 json-c libtar libnewt libproxy rpm \
8 augeas satyr systemd \
9"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
12
13
14SRC_URI = "git://github.com/abrt/libreport.git;protocol=https"
15SRC_URI += "file://0001-Makefile.am-remove-doc-and-apidoc.patch \
16 file://0002-configure.ac-remove-prog-test-of-xmlto-and-asciidoc.patch \
17 file://0003-without-build-plugins.patch \
18 file://0004-configure.ac-remove-prog-test-of-augparse.patch \
19"
20SRCREV = "15f92bcaf73e5eb8958fbde655a57dcd111757a7"
21
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
23
24S = "${WORKDIR}/git"
25
26inherit distro_features_check
27REQUIRED_DISTRO_FEATURES = "systemd"
28
29inherit gettext autotools python3native pkgconfig
30
31PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
32PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
33
34EXTRA_OECONF += "--without-python2 --with-python3"
35
36RDEPENDS_python3-libreport += "${PN}"
37
38do_patch[prefuncs] += "do_gen_version"
39do_gen_version() {
40 cd ${S}
41 ./gen-version
42}
43
44PACKAGES += "python3-libreport"
45
46FILES_${PN} += "${datadir}/*"
47FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
48FILES_python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"
49