blob: 419b3ee6e8d6f7725e6e3c5ae180d56ffc244bbc [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Set of CLI tools for Openlmi providers"
2DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
3HOMEPAGE = "http://www.openlmi.org/"
4LICENSE = "GPLv2+"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006SECTION = "System/Management"
7
8inherit setuptools
9
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
12SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
13 "
14SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
15SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
16
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017S = "${WORKDIR}/${BP}/cli"
18
19do_configure_prepend() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020 sed 's/@@VERSION@@/$(VERSION)/g' setup.py.skel >setup.py
21}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022
23python() {
24 if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
25 raise bb.parse.SkipRecipe('Requires meta-python to be present.')
26}