blob: 5fba3855c0b55452a50c695f20e5fb5e48771540 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Opensource Implementation of WS-Management"
2DESCRIPTION = "Openwsman is a project intended to provide an open-source \
3implementation of the Web Services Management specipication \
4(WS-Management) and to expose system management information on the \
5Linux operating system using the WS-Management protocol. WS-Management \
6is based on a suite of web services specifications and usage \
7requirements that exposes a set of operations focused on and covers \
8all system management aspects. \
9Openwsman Server and service libraries"
10HOMEPAGE = "http://www.openwsman.org/"
11SECTION = "Applications/System"
12
13DEPENDS = "curl libxml2 openssl libpam"
14
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "pam"
17
18SRCREV = "e90e5c96e3006c372bf45e0185e33c9250e67df6"
19PV = "2.6.5"
20
21SRC_URI = "git://github.com/Openwsman/openwsman.git \
22 file://libssl-is-required-if-eventint-supported.patch \
23 file://openwsmand.service \
24 file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \
25 file://0001-Port-to-OpenSSL-1.1.0.patch \
26 file://0002-Check-OpenSSL-version-number-to-allow-builds-with-ol.patch \
27 "
28
29S = "${WORKDIR}/git"
30
31LICENSE = "BSD"
32LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
33
34inherit systemd cmake pkgconfig pythonnative perlnative
35
36SYSTEMD_SERVICE_${PN} = "openwsmand.service"
37SYSTEMD_AUTO_ENABLE = "disable"
38
39LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
40
41EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
42 -DBUILD_LIBCIM=NO \
43 -DBUILD_PERL=YES \
44 -DCMAKE_INSTALL_PREFIX=${prefix} \
45 -DLIB=${baselib} \
46 "
47
48do_configure_prepend() {
49 export STAGING_INCDIR=${STAGING_INCDIR}
50 export STAGING_LIBDIR=${STAGING_LIBDIR}
51}
52
53do_install_append() {
54 install -d ${D}/${sysconfdir}/init.d
55 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
56 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
57 chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
58 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
59 install -d ${D}/${systemd_unitdir}/system
60 install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
61
62 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
63 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
64 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
65 fi
66}
67
68FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
69 ${libdir}/openwsman/authenticators/.debug/ \
70 "
71
72INSANE_SKIP_${PN} = "dev-so"
73RDEPENDS_${PN} = "ruby"