blob: c59a259fc3645d63b63e7830193de77bbb0531a0 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "PAM searchless LDAP authentication module"
2HOMEPAGE = "https://github.com/rmbreak/pam_ldapdb"
3BUGTRACKER = "https://github.com/rmbreak/pam_ldapdb/issues"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=41ab94182d94be9bb35e2a8b933f1e7d"
7
8DEPENDS = "libpam openldap"
9
10inherit distro_features_check
11REQUIRED_DISTRO_FEATURES = "pam"
12
13SRC_URI = "https://github.com/rmbreak/pam_ldapdb/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
14SRC_URI[md5sum] = "2dd4f1370fcfe995ee0ad09611109b87"
15SRC_URI[sha256sum] = "8ed92b36523556bb5d9bf3eb33a1035e46041d4be767c8d62136930c0ca0e45b"
16
17S = "${WORKDIR}/pam_ldapdb-${PV}"
18
19do_install () {
20 oe_runmake install DESTDIR=${D} PAMDIR=${base_libdir}/security
21}
22
23FILES_${PN} += "${base_libdir}/security/pam_ldapdb.so"