blob: ad0f66a5e1060cbec9d9a6829a65922073a7e076 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection
11
12PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
13 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \
14 bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
15 "
16
17PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
18PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
19# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
20PACKAGECONFIG[consolekit] = ",,,consolekit"
21
22PAM_SRC_URI = "file://polkit-1_pam.patch"
23SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
24 file://0001-make-netgroup-support-configurable.patch \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
26"
27SRC_URI[md5sum] = "f03b055d6ae5fc8eac76838c7d83d082"
28SRC_URI[sha256sum] = "2f87ecdabfbd415c6306673ceadc59846f059b18ef2fce42bac63fe283f12131"
29
30EXTRA_OECONF = "--with-os-type=moblin \
31 --disable-man-pages \
32 --disable-libelogind \
33 "
34
35do_compile_prepend () {
36 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
37}
38
39PACKAGES =+ "${PN}-examples"
40
41FILES_${PN}_append = " \
42 ${libdir}/${BPN}-1 \
43 ${nonarch_libdir}/${BPN}-1 \
44 ${datadir}/dbus-1 \
45 ${datadir}/${BPN}-1 \
46 ${datadir}/gettext \
47"
48
49FILES_${PN}-examples = "${bindir}/*example*"
50
51USERADD_PACKAGES = "${PN}"
52USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
53
54SYSTEMD_SERVICE_${PN} = "${BPN}.service"
55SYSTEMD_AUTO_ENABLE = "disable"