blob: c51bccce3bec3725410cab98004eafb9811a8564 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A shared storage lock manager"
2DESCRIPTION = "sanlock is a lock manager built on shared storage. Hosts with access \
3to the storage can perform locking. An application running on the \
4hosts is given a small amount of space on the shared block device or \
5file, and uses sanlock for its own application-specific synchronization. \
6Internally, the sanlock daemon manages locks using two disk-based \
7lease algorithms: delta leases and paxos leases."
8HOMEPAGE = "https://pagure.io/sanlock"
9SECTION = "utils"
10
11LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
12LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
13
14SRC_URI = "git://pagure.io/sanlock.git;protocol=http \
15 file://0001-fix-compile-failure-with-libc-musl.patch \
16 "
17SRCREV = "90b2ffa77edd46bea007b7bb39bfd4d2db2ff7af"
18S = "${WORKDIR}/git"
19
20DEPENDS = "libaio util-linux"
21
22inherit distutils
23
24do_configure[noexec] = "1"
25
26do_compile_prepend () {
27 oe_runmake -C wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
28 oe_runmake -C src CMD_LDFLAGS="${LDFLAGS}" LIB_ENTIRE_LDFLAGS="${LDFLAGS}" LIB_CLIENT_LDFLAGS="${LDFLAGS}"
29 cd ${S}/python
30}
31
32do_install_prepend () {
33 oe_runmake -C wdmd DESTDIR=${D} LIBDIR=${libdir} install
34 oe_runmake -C src DESTDIR=${D} LIBDIR=${libdir} install
35 cd ${S}/python
36}