blob: 91c50027d8b40dd1ce0b18dd04d783538750117b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Small Footprint CIM Broker"
2DESCRIPTION = "\
3Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \
4Operations over HTTP protocol. It is robust, with low resource consumption \
5and therefore specifically suited for embedded and resource constrained \
6environments. sfcb supports providers written against the Common \
7Manageability Programming Interface (CMPI)."
8HOMEPAGE = "http://www.sblim.org"
9SECTION = "Applications/System"
10LICENSE = "EPL-1.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
12DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
13
Brad Bishop316dfdd2018-06-25 12:45:53 -040014inherit distro_features_check
15REQUIRED_DISTRO_FEATURES = "pam"
16
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 file://sfcb.service \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019 file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
20 file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
21 file://sblim-sfcb-1.3.16-maxMsgLen.patch \
22 file://sblim-sfcb-1.4.5-service.patch \
23 file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
24 file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
25 file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \
27 file://0001-Replace-need-for-error.h-when-it-does-not-exist.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 file://sblim-sfcb-1.4.9-fix-sfcbinst2mof.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029"
Patrick Williamsddad1a12017-02-23 20:36:32 -060030
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
32SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
33
34inherit autotools
Brad Bishop316dfdd2018-06-25 12:45:53 -040035inherit systemd
Patrick Williamsb48b7b42016-08-17 15:04:38 -050036
37SYSTEMD_PACKAGES = "${PN}"
38SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
39SYSTEMD_AUTO_ENABLE = "enable"
40
41LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
42
43EXTRA_OECONF = '--enable-debug \
44 --enable-ssl \
45 --enable-pam \
46 --enable-ipv6 \
47 CFLAGS="${CFLAGS} -D_GNU_SOURCE"'
48
49# make all with -j option is unsafe.
50PARALLEL_MAKE = ""
51
52INSANE_SKIP_${PN} = "dev-so"
53CONFIG_SITE = "${WORKDIR}/config-site.${P}"
54
55do_install() {
56 cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg
57
58 oe_runmake DESTDIR=${D} install
59
Brad Bishop316dfdd2018-06-25 12:45:53 -040060 install -d ${D}${systemd_unitdir}/system
61 install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
Patrick Williamsb48b7b42016-08-17 15:04:38 -050062
63 install -d ${D}${sysconfdir}/init.d
64 mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
65 sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb
Patrick Williamsddad1a12017-02-23 20:36:32 -060066
Patrick Williamsb48b7b42016-08-17 15:04:38 -050067 rm -rf ${D}${libdir}/sfcb/*.la
68}
69
70pkg_postinst_${PN} () {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050071 if [ x"$D" != "x" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080072 $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050073 fi
74
75 ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
76 ${bindir}/sfcbrepos -f
77}
78
79FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb"
80FILES_${PN}-dbg += "${libdir}/sfcb/.debug"
81
82RDEPENDS_${PN} = "perl bash"