blob: c41b20c45bd51b8a809423362fadd8aa5c330d0b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The volume_key project provides a libvolume_key, a library for manipulating \
2storage volume encryption keys and storing them separately from volumes, and an \
3associated command-line tool, named volume_key."
4LICENSE = "GPLv2"
5SECTION = "devel/lib"
6
7HOMEPAGE = "https://pagure.io/volume_key"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "https://releases.pagure.org/volume_key/volume_key-${PV}.tar.xz \
12"
13SRC_URI[md5sum] = "30df56c7743eb7c965293b3d61194232"
14SRC_URI[sha256sum] = "e6b279c25ae477b555f938db2e41818f90c8cde942b0eec92f70b6c772095f6d"
15
16SRCNAME = "volume_key"
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit autotools python3native gettext
20
21DEPENDS += " \
22 util-linux \
23 glib-2.0 \
24 cryptsetup \
25 nss \
26 gpgme \
27 swig-native \
28"
29
30RDEPENDS_python3-${PN} += "${PN}"
31
32PACKAGES += "python3-${PN}"
33FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
34