blob: 947d36eb977fe13ef816ed471f1b423b9dab6dc0 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A font editor"
2HOMEPAGE = "http://fontforge.github.io/en-US/"
3LICENSE = "BSD-3-Clause & GPLv3"
4LIC_FILES_CHKSUM = " \
5 file://COPYING.gplv3;md5=d32239bcb673463ab874e80d47fae504 \
6 file://LICENSE;md5=3f922b42ed0033fa0fd4cd3268f6429c \
7"
8
Brad Bishop316dfdd2018-06-25 12:45:53 -04009DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gnulib gettext-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010DEPENDS_append_class-target = " libxi"
11
12inherit autotools pkgconfig pythonnative distro_features_check gettext
13
14REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
15
16SRC_URI = "git://github.com/${BPN}/${BPN}.git"
17# tag 20170731
18SRCREV = "b9149c13e8f9464fc21473f1f676b36a2130775d"
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF_append_class-native = " with_x=no"
22
23do_configure_prepend() {
24 # uthash sources are expected in uthash/src
25 currdir=`pwd`
26 cd ${S}
27
28 mkdir -p uthash/src
29 cp ${STAGING_INCDIR}/ut*.h uthash/src
30
31 # avoid bootstrap cloning gnulib on every configure
32 cat >.gitmodules <<EOF
33[submodule "gnulib"]
34 path = gnulib
35 url = git://git.sv.gnu.org/gnulib
36EOF
37 cp -rf ${STAGING_DATADIR}/gnulib ${S}
38
39 # --force to avoid errors on reconfigure e.g if recipes changed we depend on
40 # | bootstrap: running: libtoolize --quiet
41 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
42 # | ...
43 ./bootstrap --force
44
45 cd $currdir
46}
47
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080048PACKAGES =+ "${PN}-python"
49
50RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051
52FILES_${PN} += " \
53 ${datadir}/mime \
54 ${datadir}/icons \
55"
56
57FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${PN}/python"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050058RDEPENDS_${PN}-python = "python"
59
60# for e.g kde's oxygen-fonts
61BBCLASSEXTEND = "native"