blob: 943986e77e10de29d94dbe93e41f3bc6432729b5 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gtk+ \
12 babl \
13 gegl \
14 jpeg \
15 libpng \
16 libexif \
17 tiff \
18 lcms \
19 poppler \
20 jasper \
21 bzip2 \
22 libgudev \
23 libmng \
24"
25DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
26
Brad Bishop316dfdd2018-06-25 12:45:53 -040027inherit distro_features_check gnome gtk-doc
28
29REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030
31SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
32 file://0001-configure-ac-do-not-check-for-freetype-config.patch \
33 file://bump_Babl-GEGL_versions.patch \
34 file://0003-Fix-use-of-gegl-API.patch \
35 "
36SRC_URI[md5sum] = "7e4fd7a53b1d3c32dff642ab1a94b44d"
37SRC_URI[sha256sum] = "9187a35cc52b110d78124d7b27b68a68ade14a794c2721314bac6134d2a5638a"
38
39EXTRA_OECONF = "--disable-python \
40 --without-webkit \
41 --without-wmf"
42
43do_configure_append() {
44 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
45 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
46}
47
48CFLAGS += "-fPIC"
49
50FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
51FILES_${PN} += "${datadir}/appdata"