blob: 8d23bd5eb85e5ae220fa75d70ac449b85be31cbc [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
8AUTHOR = "Martin Kepplinger <martink@posteo.de>"
9SECTION = "base"
10LICENSE = "LGPLv2+ & GPLv2+"
11LIC_FILES_CHKSUM = "\
12 file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
13 file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
14"
15
16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
17 file://ts.conf \
18 file://tslib.sh \
19"
20SRC_URI[md5sum] = "254a022fc8aa89d164840fe8869c2441"
21SRC_URI[sha256sum] = "c9a54651337a701a66b074c603c313225579995a7910e519bbc7b1dcdab9a755"
22
23UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
24
25inherit autotools pkgconfig
26
27PACKAGECONFIG ??= "debounce dejitter iir linear median pthres skip lowpass invert variance input touchkit waveshare"
28PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
29PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
30PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
31PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
32PACKAGECONFIG[median] = "--enable-median,--disable-median"
33PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
34PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
35PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
36PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
37PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
38PACKAGECONFIG[input] = "--enable-input,--disable-input"
39PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
40PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
41PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
42PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
43PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
44PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
45PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
46PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
47PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
48PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
49PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
50PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
51PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
52PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
53PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
54
55do_install_prepend() {
56 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
57}
58
59do_install_append() {
60 install -d ${D}${sysconfdir}/profile.d/
61 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
62}
63
64RPROVIDES_tslib-conf = "libts-0.0-conf"
65
66PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
67DEBIAN_NOAUTONAME_tslib-conf = "1"
68DEBIAN_NOAUTONAME_tslib-tests = "1"
69DEBIAN_NOAUTONAME_tslib-calibrate = "1"
70DEBIAN_NOAUTONAME_tslib-uinput = "1"
71
72RDEPENDS_${PN} = "tslib-conf"
73RRECOMMENDS_${PN} = "pointercal"
74
75FILES_${PN}-dev += "${libdir}/ts/*.la"
76FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
77FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
78FILES_tslib-calibrate += "${bindir}/ts_calibrate"
79FILES_tslib-uinput += "${bindir}/ts_uinput"
80
81FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
82 ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev"