blob: b047bc46289dda9251cced41426a1a9c7405bab2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Exports your X session on-the-fly via VNC"
2HOMEPAGE = "http://www.karlrunge.com/x11vnc/"
3
4SECTION = "x11/utils"
5AUTHOR = "Karl Runge"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f \
8 file://x11vnc/x11vnc.h;endline=33;md5=6f95dc6535467d7ee1563fd434fb372e"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc/${PV}/x11vnc-${PV}.tar.gz\
11 file://starting-fix.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060012 file://endian-fix.patch \
13 file://remove-redundant-RPATH.patch \
14"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16SRC_URI[md5sum] = "a372ec4fe8211221547b1c108cf56e4c"
17SRC_URI[sha256sum] = "f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a59f13b"
18
19DEPENDS = "openssl virtual/libx11 libxext jpeg zlib libxfixes libxrandr libxdamage libxtst libtasn1 p11-kit"
20
21inherit autotools-brokensep distro_features_check
22# depends on virtual/libx11
23REQUIRED_DISTRO_FEATURES = "x11"
24
25PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} libvncserver"
26PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"
27PACKAGECONFIG[xinerama] = "--with-xinerama,--without-xinerama,libxinerama"
28PACKAGECONFIG[libvncserver] = "--with-system-libvncserver,--without-system-libvncserver,libvncserver"
Patrick Williamsddad1a12017-02-23 20:36:32 -060029
30do_prepare_sources () {
31 # Remove old libtool macros from acinclude.m4
32 sed -i -e '/^# libtool.m4/q' ${S}/acinclude.m4
33}
34do_patch[postfuncs] += "do_prepare_sources"