blob: c2feb81070c50b6de415068d3d1240f4289cc667 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require recipes-graphics/xorg-app/xorg-app-common.inc
2SUMMARY = "xterm is the standard terminal emulator for the X Window System"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004
5LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=f02ab9ebda87b770ecf711dbb3784a33"
6
7SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
8
9SRC_URI[md5sum] = "9a6db7974aa4ccbb50eabebf72618467"
10SRC_URI[sha256sum] = "7aeef9f29f6b95e09f481173c8c3053357bf5ffe162585647f690fd1707556df"
11PACKAGECONFIG ?= ""
12PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
13
14EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
15 --x-libraries=${STAGING_LIBDIR} \
16 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
17 --disable-imake \
18 --disable-rpath-hack \
19 --disable-setuid"
20
21B = "${S}"
22
23do_configure() {
24 gnu-configize --force
25 sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
26 oe_runconf
27}
28
29FILES_${PN} += "/usr/lib/X11"
Brad Bishop316dfdd2018-06-25 12:45:53 -040030
31# busybox can supply resize too
32inherit update-alternatives
33
34ALTERNATIVE_${PN} = "resize"