blob: fd0653ab872d245c360bc5a2f3f6ea4c12c62aea [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Inspect and manipulate eBPF programs and maps"
2DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
3of eBPF programs and maps."
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
6DEPENDS = "binutils elfutils"
7PROVIDES = "virtual/bpftool"
8
9inherit bash-completion kernelsrc kernel-arch
10
11do_populate_lic[depends] += "virtual/kernel:do_patch"
12
13EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
14
15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16
17do_compile() {
18 oe_runmake
19}
20
21do_install() {
22 oe_runmake DESTDIR=${D} install
23}
24
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26
27python do_package_prepend() {
28 d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
29}
30
31B = "${WORKDIR}/${BPN}-${PV}"